Krautkanal.com

Veröffentlicht am 2017-08-13 23:56:2 in /c/

/c/ 219855: Visual C++ 2015 x64 Runtime karpott

slaterjohn Avatar
slaterjohn:#219855

Visual C++ 2015 x64. Es wird von diversen Installern in
>C:\ProgramData\Package Cache\{7B50D081-E670-3B43-A460-0E2CDB5CE984}v14.0.23918\packages\vcRuntimeMinimum_amd64\
vermisst, siehe rechts oben.
Also habe ich es installieren wollen, angeblich ist es schon da, siehe rechts unten.
Wenn ich es in Windows 10x64 Pro aber deinstallieren will, kann er es zum deinstallieren gar nicht finden, bricht die Deinstallation ab und zeigt es weiterhin als installiert an, siehe links.
Was tun?

christauziet Avatar
christauziet:#219856

Warum hast Du auch darin herumgelöscht? Das ist genau so ein Russisch-Roulette-Spiel wie im %windir%\Installer oder %windir%\syswow64 Ordner herumzulöschen, weil frisst ja soundsovielGB

Versuche es mal damit:
https://www.microsoft.com/de-DE/download/details.aspx?id=52685

yassiryahya Avatar
yassiryahya:#219858

OP muss nichts gelöscht haben. Das können auch Software- und Hardwarefehler gemacht haben. Habe gleiche Problem mit älterem Visual C++. Bisher keine Lösung außer Neuinstallation oder Wiederherstellen aus einer noch funktionierenden Sicherung.

mr_arcadio Avatar
mr_arcadio:#219859

>>219858
> Bisher keine Lösung außer Neuinstallation

Funktioniert doch bei OP gar nicht! m(

oaktreemedia Avatar
oaktreemedia:#219865

Es hat schon seinen Grund, warum immer mehr Leute auf OSX/iOS umsteigen.

mat_stevens Avatar
mat_stevens:#219867

>>219859
Gemeint ist die Neuinstallation von Windows.

nateschulte Avatar
nateschulte:#219869

Hat OP schonmal versucht den Ordner zu löschen?

snowshade Avatar
snowshade:#219872

>>219856
>Warum hast Du auch darin herumgelöscht?
Habe ich nicht.
>Versuche es mal damit:
Hat nicht geklappt.

>>219869
Nicht bevor das Problem auftrat, erst als es nicht deinstalliert werden wollte. Bringt aber auch nix.

jacobbennett Avatar
jacobbennett:#219873

Vielleicht mal mit SFC versuchen es wieder zu flicken.
https://support.microsoft.com/de-de/help/929833/use-the-system-file-checker-tool-to-repair-missing-or-corrupted-system

Bei dem Screenshot von OP kräuseln sich echt meine Fußnägel wegen den Firefox-Addons

carlyson Avatar
carlyson:#219875

>>219873
> wegen den Firefox-Addons
Es heißt wegen die Firefox-Addons.

fatihturan Avatar
fatihturan:#219877

>>219875
die
der
der
die

Sollte bekannt sein, oder?

jasontdsn Avatar
jasontdsn:#219884

>>219877
Es heißt wegen *der* Addons, wenn wir schon klugscheißen wollen.

SFC habe ich leider schon probiert, da werde ich wohl am Wochenende neu aufsetzen dürfen.
Ich frage mich nur wie es dazu kommen konnte dass die Datei nicht da ist, obwohl VC++2k15x64 weder vollständig deinstalliert, noch von mir manuell gelöscht wurde.
Ich meine ist ja schön und gut wenn ich halt Windows neu aufsetzen muss, das werd ich schon überleben.
Aber es wäre ja schon enorm kacke, wenn das dann in absehbarer Zeit erneut auftritt.

sindresorhus Avatar
sindresorhus:#219887

>>219884
Hattest du ein in place Upgrade innerhalb von Windows 10?

pakhandrin Avatar
pakhandrin:#219899

>>219884
Bernd meint nach etwas Recherche herausgefunden zu haben: Das VC++ Redistributable wird in Form einer Setup-Datei namens vc_redist.x64.exe ausgeliefert. Diese installiert dann zwei MSI-Pakete, nämlich vcRuntimeMinimum_x64 und vcRuntimeAdditional_x64. Wahrscheinlich entpackt die Setup-Datei die MSI-Pakete vor dem Installieren nach %ProgramData%\Package Cache.

Aus irgendwelche Gründen scheint bei dir genau dieser Package Cache verloren gegangen zu sein. Und zwar für beide Versionen vom C++ Redistributable, die bei dir installiert sind (14.0.24210 und 14.0.23918.0). Evtl. hast du sogar noch meer als diese zwei Versionen installiert.

Bernd fallen nun folgende mögliche Lösungsansätze ein:

1) Evtl. kannst du in der Apps&Features-Liste, die auch in deinem Bildschirmschuss links zu sehen ist, mit der rechten Maustaste auf ein Paket und dann auf "Reparieren" klicken. Bernd kann das mangels Windows 10 allerdings nicht testen. Wenn du Glück hast, dann lässt sich das Problem beheben. Es könnte aber auch wieder eine der bekannten Fehlermeldungen kommen.

2) Du suchst die vc_redist.x64.exe-Dateien mit den exakten Versionsnummern, die bei dir installiert sind und installierst sie dann erneut. Version 14.0.23918.0 hat Bernd hier gefunden:
http://download.microsoft.com/download/4/c/b/4cbd5757-0dd4-43a7-bac0-2a492cedbacb/vc_redist.x64.exe
Bei der anderen Version hatte Bernd leider kein Glück.

3) Der Windows-Installer kopiert automatisch alle MSI-Dateien bei der Installation nach %windir%\installer. Details siehe hier:
https://stackoverflow.com/a/2071984
Du kannst dir also über die Registry die lokalen Kopien von vcRuntimeMinimum_x64.msi und vcRuntimeAdditional_x64.msi suchen und dann reparieren oder gleich deinstallieren. Müsste beides über einen Rechtsklick auf die entsprechende Datei im Explorer funktionieren.

4) Du kannst über die Konsole mit msiexec /x <product code> ein Paket manuell deinstallieren (evtl. musst du die Konsole als Adminstrator ausführen). Dazu musst du den Product-Code wissen, in deinem Fall sind das die Product-Codes der installierten vcRuntimeMinimum_x64- und vcRuntimeAdditional_x64-Pakete. Genaue Erklärung ist hier:
https://blogs.msdn.microsoft.com/astebner/2005/07/01/using-msiinv-to-gather-information-about-what-is-installed-on-a-computer/
Dieses msiinv-Tool hat Bernd nur noch hier gefunden:
http://www.experimentalspace.com/index.php/2008/04/error-when-trying-to-install-full-visual-studio-you-must-uninstall-all-the-pre-release-products-in-a-specific-order-before-you-can-continue-with-setup/
Keine Ahnung, wie vertrauenswürdig diese Quelle ist. Vielleicht vorher mit VirusTotal prüfen.